Today I made my first fligt with the new Version 1.4

I must say: this is NOT acceptable! I flew from Austria to Slowenia (LJPZ). As long as I was in the austrian airspace, the APP was stable but slow. From time to time I got a window that I have lost my Internet connection because of a lack of WLAN. I was in 7000 ft - there is no WLAN.

Minutes afte crossing the boarder to Slowenia the APP crashed. A restart was required. The APP crashed about 10 times enroute before I switched it OFF. The pilots duty is to operate an airplane not a APP on an iPad!

In Portoroz I was deleting most of the countrys. No help.

For the return flight the APP crashed 3 times from parking position to Take Off point.

I used my old Garmin 269 for navigation. When reaching austrian airspace  I switched the APP ON again

and it worked (slow but stable) until landing in LOWZ....

I really hope for an update very soon to correct all these peoblems!

Views: 549

Reply to This

Replies to This Discussion


Hello Alois,

we are very sorry for any inconvenience. As mentioned, since we first heard about these spoardic crashes, we've conducted tests to close in on this subject. As a temporary workaround, in most cases it is helpful to remove unused countries from the app.

A fix has already been developed, is in testing, and will be available in the AppStore shortly.

For the "Mobile FliteDeck VFR" Team,


Hi everyone,

We (an aeroclub from Austria) had a nice trip from May 1st to 4th this year - the trip was from LOAV --> LIPV --> LFMD --> LESL --> LFKF -->  LJPZ -- back to LOAV. I used FD VFR V1.4 for planning the whole trip (and during the trip of course). I really appreciate the recently released countries! Even the "Enroute Coverage" is more that I have expected after the long time with no additional countries - well done! (Now only Hungary is a white spot). 

In-flight experience: Basically OK - but there are stability issues (as mentioned above), which are annoying. Crashes and hangups on zooming in and scrolling. The app takes some drain on the battery - if you put off (not power down) the iPad, in 6 out of 10 cases the app dies. (Equipment: iPad 4th Gen 64GB, all other apps closed)

Overall: Please fix the stability issues - anyway: the additional countries are a real value!




I had the same issue today. First hour into the flight everything as usual (i.e. good, since I really think this is a great app), but after an hour I got the pop-up window "Internet Connection lost..." and when I clicke it away a new window popped up (CONNECTION STATUS or something similar). When I clicked that second window away, the first one re-appeared. I tried killing and restarting the app, but no improvement. In the end I stopped fiddling with the iPad and flew without it.

This really is a drawback, since inflight stability is one of the most important aspects. I have to be able to rely on my moving map (and as mentioned by Alois, we cannot spend our time fiddling with a gadget; we have to fly).

I hope this will be amended very, very soon.

Kind regards


Same for me today.
On a short flight of about 30 min, the wlan message apeared at least 4 times.
Please fix asap
Hello, I have the Same problems in flight with the internet connection. Also at flightplanning it is not possible to Zoom in, the app crash. In the ipad settings is a message "crash due to low memory".
Please fix it asap, cause it is not possible on my iPad mini 1 to plan a trip.
I have a iPad mini 1 with 64GB.
Greetings Oliver

Dear Jeppesen-Team

There seems to be quite a bunch of people experiencing the same serious problems with the Mobile Flight Deck VFR at the moment.

I have already asked via e-mail but did not get a reply, so I ask again here: As long as the app doesn't run stable, we cannot use it. When it makes us fumble and fiddle around with the iPad in flight we actually don't gain safety but are rather distracted and this decreases the safety level. Therefore, I'm sorry to say, bu at the moment, the app is of no use.

Since we pay quite a lof for the app, I would like to enquire whether Jeppesen offers a prolongation for the time that the app is out of service.

Furthermore I would greatly appreciate an indication as to when Jeppesen intends to fix the issue, so that we can continue using it again.

I'm looking forward to hearing from you.

Kind regards


Dear all,


A new release (version 1.41) including Bug Fixes and Performance Enhancements has been sent to Apple for approval. With this patch the stability of the app will be back to normal. In addition to that, the “no internet connection” messages in flight mode will be gone as well. We expect this patch to be available in the AppStore very soon. We apologize for any inconveniences. 


For the “Mobile FliteDeck VFR” Team

Dear all,

Release 1.4.1 comprising Bug fixes, Rendering and Performance Enhancements has been released and is available in the AppStore.

For the Mobile FliteDeck VFR team

I just landed from a flight from LOAV to LJMB. Before takeoff I installed 1.4.1 - the new version!
Airborne an climbing the app gave me the "not connected to internet" messages. I acknowldged those - but it remained at "Activating" and wanted me to enter the password. A restart of the app did not help --> wants activating.......
Thanks god: I have AirnavPro on the iPad - it had not the smallest hickup!

You know what I do now ? I DEINSTALL the damn JeppVFR app - I dont want to depend on a SW with this quality!

The chapter JeppVFR is closed for me!


Hello Gerhard,

as discussed offline, we have tested a lot, but we could not reproduce the above mentioned scenario after updating to 1.4.1.

As far as we know, no other customer has experienced a similar behavior of the app. We got a lot of customer feedback on different channels. All confirmed the stability of 1.4.1.

However, we are still investigating to find some facts which might explain the scenario you have experienced.

For the "Mobile FliteDeck VFR" Team,


I have now made 8 legs wirh the new update, and would like to thank you for your efforts. On 6 legs there was no problem, but on two legs the "you lost internet connection"-window appeared. Luckily enough and contrary to the old version (prior to the 1.4.1 release) the window disappeared after the second or third click. So ober all I would say the problem has (only) almost disappeared. It would be great if you could fix this for good, since it does leave a feeling of "Hopefully it doesn't crash"... On a different topic: the app has now been unfunctional for several weeks. Are you planning on prolonging the subscriptions accordingly, since basicsally we were paying for a non-functional app. I'm looking forward to hearing from you. Kind regards, Stephan
Dear Jeppesen Team
I have recently raised the question whether you will extend our subscription but unfortunately you seem to be avoiding the topic. I therefore again would like to hear your point of view. In my opinion the app was (completely!) unfunctional for several weeks, since an app which crashes on almost every flight is of no use to a pilot. Even if the problem seems to be solved now (at least I hope so), I feel it would be more than appropriate to extend our subscription accordingly. Please bear in mind that we did pay our subscription fee but that Jeppesen did not deliver a functional app.
I'm looking forward to hearing from you.
Kind regards

Reply to Discussion




In this category you will find discussion which should support you in finding answers regarding general or technical questions.

123 discussions


Here we share useful information about new features and functions of Jeppesen Mobile FliteDeck VFR.

1 discussions

Blog Posts

iOS 12 Compatibility

Posted by Lars Wedegärtner on October 8, 2018 at 1:37am 0 Comments

iOS 12

Posted by Lars Wedegärtner on September 19, 2018 at 9:31am 1 Comment

iOS 12

Posted by Lars Wedegärtner on September 19, 2018 at 9:29am 0 Comments

© 2019   Jeppesen   Powered by

Badges  |     |  Terms of Service