System Requirements

Mobile FliteDeck VFR 2.3.0 Technical Requirements:

iPad Compatibility:

iPad© Pro

iPad© Air

iPad© 4

iPad© 3

iPad© Mini Retina

iOS Supported Version:

The list of supported devices for Mobile FliteDeck VFR 2.2.1 is related to devices running with iOS 10.3.3 and iOS11.0

Please note that this does not include iPad (1st generation), iPad2 and iPad Mini.

Minimum HardDisk Space:

    Europe Coverage - approx. 3 GB

Internet Connection:

    WiFi & 3G

Forum

PRODUCT SUPPORT

In this category you will find discussion which should support you in finding answers regarding general or technical questions.

124 discussions

PRODUCT TIPS & TRICKS

Here we share useful information about new features and functions of Jeppesen Mobile FliteDeck VFR.

1 discussions

Blog Posts

Final Notice on MFD VFR

Posted by Lars Wedegärtner on April 1, 2020 at 1:00am 0 Comments

ForeFlight Mobile Webinar

Posted by Lars Wedegärtner on December 17, 2019 at 8:30am 0 Comments

iOS 13.2/13.3 crashes

Posted by Lars Wedegärtner on November 29, 2019 at 4:00am 0 Comments

iOS 13 Compatibility

Posted by Lars Wedegärtner on November 14, 2019 at 6:50am 7 Comments

© 2020   Jeppesen   Powered by

Badges  |     |  Terms of Service